Bienvenu dans ce nouveau tuto Excel sur la fonction N() !

Il est fort probable que vous ne connaissiez pas la fonction N() dans Excel. Cette fonction peut paraitre, a priori, sans réelle utilité… Mais détrompez-vous ! C’est ce que nous allons détailler dans cet article.

Description

Cette fonction convertit des données d’entrées en valeurs numériques :

  • S’il s’agit d’un nombre, la fonction renvoie ce nombre
  • Pour une date, la fonction renvoie le numéro de série de cette date
  • Pour les valeurs logiques VRAI et FAUX, la fonction renvoie respectivement 1 et 0
  • La fonction renvoie la valeur d’une erreur (#N/A, #DIV0!, #NOM?…)
  • Pour toutes les autres valeurs, la fonction N renvoie 0

 

Vu comme cela, il n’est pas évident que cette fonction apporte grand-chose… Mais combinée à d’autres fonctions, elle peut s’avérer bien pratique !

Formules matricielles

Il est possible de shunter une formule matricielle (cf. article https://www.experts-excel.com/excel/tuto-excel-fonctions-agregat-max-si-ens-et-formule-matricielle/).

Dans l’exemple ci-dessous, nous souhaitons compter le nombre de cellules possédant plus de 100 caractères :

Pour cela, il est possible d’utiliser la fonction matricielle : 

{=SOMMEPROD(SI(NBCAR(C5:C9)>100;1;0))}

Les crochets apparaissent lorsque vous validez la formule en effectuant un Ctrl+Alt+Entrée

 

Grâce à la fonction N, on peut s’affranchir de la formule matricielle :

=SOMMEPROD(N(NBCAR(C5:C9)>100))

La fonction NBCAR(C5:C9)>100 va retourner des VRAI/FAUX :

=SOMMEPROD(N({VRAI;FAUX;VRAI;FAUX;VRAI}))

Et donc la fonction N va convertir les VRAI en 1 et les FAUX en 0.

Et donc, on obtient in fine, le résultat escompté !

Compter les colonnes masquées

Il est relativement aisé de compter le nombre de lignes visibles.

Mais la fonction SOUS.TOTAL ne fonctionne pas si on veut compter le nombre de colonnes masquées.

La fonction =CELLULE(“largeur”;C4) retourne la « taille » de la colonne. Donc, l’utilisation de la formule =N(CELLULE(“largeur”;B4)>0) va renvoyer 0 ou 1.

Il suffit donc d’effectuer la somme de ces cellules pour obtenir le nombre de colonne visibles. Et par déduction, on peut obtenir le nombre de colonnes masquées :

=COLONNES($B$3:$F$3)-SOMME($B$3:$F$3)

Commentaire dans une formule

Il est également possible d’utiliser la fonction N pour y mettre du texte sans que cela interfère dans une formule de calcul.

Dans cet exemple, quatre amis ont décidé de créer une cagnotte de départ.

Il est ainsi possible de faire le détail des montants mis par personne, et cela dans une seule cellule. 

Conclusion

Excel regorge de petites fonctions qui peuvent être anodines de prime abord. Mais en y regardant de plus près, on peut en faire de grandes choses !

Les Experts Excel vous proposent des formations, du développement, de l’expertise et de l’assistance sur Microsoft Excel. N’hésitez plus et contactez-les dès maintenant !